الرئيسية > أنظمة يونكس > رسالة الخطأ SVN: This client is too old to work with working copy

رسالة الخطأ SVN: This client is too old to work with working copy


السلام عليكم و رحمة الله و بركاته

أثناء تحديث Metasploit 4 تأتيني هذه الرسالة:

root@bt:/opt/msf4# msfupdate
svn: This client is too old to work with working copy '.'.  You need
to get a newer Subversion client, or to downgrade this working copy.
See http://subversion.tigris.org/faq.html#working-copy-format-change
for details.

بعد البحث وجدت أن إصدارة subversion تغيرت و عليه يجب التحويل من الإصدارة القديمة إلى الإصدارة الجديدة، كيف ذلك؟ الحل مع هذا السكريبت change-svn-wc-format.py،
قم أولا بتحميله :

root@bt:/opt# wget https://svn.apache.org/repos/asf/subversion/trunk/tools/client-side/change-svn-wc-format.py

بعدها قم نبتشغيله كالآتي:

root@bt:/opt# python change-svn-wc-format.py /pentest/exploits/framework/ 1.5

ستضهر الرسالة التالية:

Converted WC at '/pentest/exploits/framework/' into format 9 for Subversion 1.5

الآن يمكنك تحديث ال Metasploit:

root@bt:/opt# cd framework
root@bt:/opt/framework# msfupdate
[*]
[*] Attempting to update the Metasploit Framework...
[*]
<strong>

 

التصنيفات :أنظمة يونكس الوسوم:
  1. 29 مايو 2014 الساعة 12:04 م

    بارك الله فيك أخي

  1. No trackbacks yet.

أضف تعليقاً

إملأ الحقول أدناه بالمعلومات المناسبة أو إضغط على إحدى الأيقونات لتسجيل الدخول:

WordPress.com Logo

أنت تعلق بإستخدام حساب WordPress.com. تسجيل خروج   / تغيير )

صورة تويتر

أنت تعلق بإستخدام حساب Twitter. تسجيل خروج   / تغيير )

Facebook photo

أنت تعلق بإستخدام حساب Facebook. تسجيل خروج   / تغيير )

Google+ photo

أنت تعلق بإستخدام حساب Google+. تسجيل خروج   / تغيير )

Connecting to %s

%d مدونون معجبون بهذه: